Back to overview
Resolved

Paid Services Downtime

Jan 13, 2026 at 9:43am UTC

Resolved
Jan 13, 2026 at 9:43am UTC

Recently Paid services was down. They are successfully restored back and 3 days compensation was given to all paid users faced this issue